TOPIC: How to compile libx264 with ffmpeg?

How to compile libx264 with ffmpeg? 5 years 1 month ago #16643

FFmpeg version SVN-r19555, Copyright (c) 2000-2009 Fabrice Bellard, et al.
configuration: --prefix=/home/wizardhead --enable-cross-compile --enable-shared
libavutil 50. 3. 0 / 50. 3. 0
libavcodec 52.32. 0 / 52.32. 0
libavformat 52.36. 0 / 52.36. 0
libavdevice 52. 2. 0 / 52. 2. 0
libswscale 0. 7. 1 / 0. 7. 1
built on Jul 30 2009 23:14:08, gcc: 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)

Seems stream 1 codec frame rate differs from container frame rate: 1000.00 (1000/1) -> 30.00 (30/1)
Input #0, asf, from '/home/wizardhead/unicpu.net/components/com_hwdvideoshare/converters/../../../hwdvideos/uploads/originals/7mbeviq7twsbw5.wmv':
Duration: 00:01:31.01, start: 3.100000, bitrate: 227 kb/s
Stream #0.0: Audio: wmav2, 32000 Hz, 2 channels, s16, 32 kb/s
Stream #0.1: Video: wmv1, yuv420p, 320x240, 30 tbr, 1k tbn, 1k tbc
Unknown encoder 'libx264'
FFmpeg version SVN-r19555, Copyright (c) 2000-2009 Fabrice Bellard, et al.
configuration: --prefix=/home/wizardhead --enable-cross-compile --enable-shared
libavutil 50. 3. 0 / 50. 3. 0
libavcodec 52.32. 0 / 52.32. 0
libavformat 52.36. 0 / 52.36. 0
libavdevice 52. 2. 0 / 52. 2. 0
libswscale 0. 7. 1 / 0. 7. 1
built on Jul 30 2009 23:14:08, gcc: 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)

Seems stream 1 codec frame rate differs from container frame rate: 1000.00 (1000/1) -> 30.00 (30/1)
Input #0, asf, from '/home/wizardhead/unicpu.net/components/com_hwdvideoshare/converters/../../../hwdvideos/uploads/originals/7mbeviq7twsbw5.wmv':
Duration: 00:01:31.01, start: 3.100000, bitrate: 227 kb/s
Stream #0.0: Audio: wmav2, 32000 Hz, 2 channels, s16, 32 kb/s
Stream #0.1: Video: wmv1, yuv420p, 320x240, 30 tbr, 1k tbn, 1k tbc
Unknown encoder 'libx264'
thats the error i get when i try to convert a video via backend when it was uploaded via frontend and i know i compiled it, but this is the error i get when i try to enable it when i try to compile it into ffmpeg "libx264 Not Found"

could someone please help me, ive managed to get ffmpeg and flvtool2 compiled on my sever next thing is that codec :(
If You Have Computer Problems or need a video tutorial on how to fix it? or need support to guide you through on how to fix your computer problem?
Well Come Here Where You Can Get All That And More
Universal Computers
If We Can't Do It, It Can't Be Done
The topic has been locked.

Re:How to compile libx264 with ffmpeg? 5 years 1 month ago #16660

  • marpada
  • marpada's Avatar
  • OFFLINE
  • Moderator
  • Posts: 5065
  • Thank you received: 150
Check our guide and the one at www.netbrix.net/archives/20 as a reference.

First you have to download, unzip, configure, make and make install libx264 AND libfaac, but remember that in every configure step you have to add --prefix=$HOME .

One these are compiled, you have to compile ffmpeg again, including --enable-libx264 and --enable-libfaac in the configure step.
The topic has been locked.

Re:How to compile libx264 with ffmpeg? 5 years 1 month ago #16703

marpada wrote:
Check our guide and the one at www.netbrix.net/archives/20 as a reference.

First you have to download, unzip, configure, make and make install libx264 AND libfaac, but remember that in every configure step you have to add --prefix=$HOME .

One these are compiled, you have to compile ffmpeg again, including --enable-libx264 and --enable-libfaac in the configure step.


i cant compile libfaac its saying that im missing something like autoconfig when i try to install it :( what am i doing wrong now?

and i got it compiled with lib264 but then i dont hear any sound :(

can someone please do it for me? i can send u the sever details
If You Have Computer Problems or need a video tutorial on how to fix it? or need support to guide you through on how to fix your computer problem?
Well Come Here Where You Can Get All That And More
Universal Computers
If We Can't Do It, It Can't Be Done
The topic has been locked.

Re:How to compile libx264 with ffmpeg? 5 years 1 month ago #16704

[cavs]$ ./bootstrap
./bootstrap: line 3: aclocal: command not found
./bootstrap: line 4: autoheader: command not found
./bootstrap: line 8: libtoolize: command not found
./bootstrap: line 10: automake: command not found
./bootstrap: line 11: autoconf: command not found

thats the error i get :( when i try

$ wget superb-west.dl.sourceforge.net/sourcefor...aac/faac-1.28.tar.gz
$ tar xvfz faac-1.28.tar.gz
$ cd faac-1.28/
$ ./bootstrap
If You Have Computer Problems or need a video tutorial on how to fix it? or need support to guide you through on how to fix your computer problem?
Well Come Here Where You Can Get All That And More
Universal Computers
If We Can't Do It, It Can't Be Done
The topic has been locked.

Re:How to compile libx264 with ffmpeg? 5 years 1 month ago #16741

  • marpada
  • marpada's Avatar
  • OFFLINE
  • Moderator
  • Posts: 5065
  • Thank you received: 150
don't know what's that bootstrap thing, just stick to the ./configure --prefix=$HOME, make and make install as for the other codecs
The topic has been locked.
Time to create page: 0.248 seconds
Powered by Kunena Forum

Let's keep in touch

Sign up and get a free hug!

Enter your name and email address if you want to receive our newsletter. We send one newsletter a month, and we will never sell your details, period.

Powerful Media...

We have been using Hwd products for over a year and are just now migrating to the new HwdMediaShare. The development keeps improving making the component more and more complete. Dave, the lead...

Read more

Brilliant Extension...

Completely recommend this component. We utilise it to manage a large array of media and have found it to be totally supportive and powerful, it meets our needs completely and in a very professional...

Read more

Video Access...

I am developing a site to display videos to users with different Joomla access levels. This product allows me to do that and keeps those videos separate from those uploaded by members in the...

Read more

Blows other...

This component is amazing, it can do so many things and the support in the is top-notch!! The support is quick, thoughtful and very helpful. I continue to be impressed with the sheer amount of...

Read more

Great Component!...

I tried several free components, and purchased another component and none met my needs. Then I purchased HWDMediaShare. There was a learning curve, but this component met and exceeded my needs and...

Read more

Best Mediashare...

I set up a new video-tube and tried many components (free and paid). I need some special features for my site and with each component I reached early the limits, although some of them cost several...

Read more

Absolutely great...

This is an amazing extension with great features. Lots of customization and easy to manage 1000s media. Developers are very responsive and when requested some new features, they developed them with...

Read more

Simply the best...

Stop looking for other multi-media display solutions! This is what you need to go with. The support is phenomenal, the component does exactly what it says, and the forum provides ideas and solutions...

Read more